Menu and Toolbar (Scripting)

<< Click to Display Table of Contents >>

Navigation:  Reference >

Menu and Toolbar (Scripting)

NOTE: Hotkeys are available for common menu and toolbar functions.

 

File Menu

 

NEW New Project

Close the current Docklight project and create a new one.

 

OPEN Open Project ...

Close the current Docklight project and open another project.

 

Import Sequence List ...

Import all Send Sequences and Receive Sequences from a second Docklight project.

 

SAVE Save Project / Save Project As ...

Save the current Docklight project.

 

Print Project ...

Print the project data, i.e. the list of defined Send Sequences and Receive Sequences. The sequences are printed in the same representation (ASCII, HEX, Decimal or Binary) that is used in the Docklight main window. The representation may be chosen using the Options dialog window.

 

PRINT Print Communication ...

Print the contents of the communication window. The communication data is printed in the same representation that is currently visible in the communication window.

 

Exit

Quit Docklight.

 

Edit Menu

 

Edit Send Sequence List ...

Edit the Send Sequences list, i.e. add new sequences or delete existing ones.

 

Edit Receive Sequence List ...

Edit the Receive Sequences list, i.e. add new sequences or delete existing ones.

 

Swap Send and Receive Sequence Lists

Convert all Send Sequences into Receive Sequences and vice versa.

 

BINOCULR Find Sequence in Communication Window...

Find a specific sequence within the data displayed in the communication window. See the Find Sequence function.

 

CleanCommWindow Clear Communication Window

Delete the contents of the communications window. This applies to all four representations (ASCII, HEX, Decimal, Binary) of the communication window.

 

Run Menu

 

play Start communication

Open the communication ports and enable serial data transfer.

 

stop Stop communication

Stop serial data transfer and close the communication ports.

 

Tools Menu

 

logging Start Communication Logging ...

Create new log file(s) and start logging the incoming/outgoing serial data. See logging and analyzing a test.

 

nologging Stop Communication Logging

Stop logging and close the currently open log file(s).

 

snapshot_start Start Snapshot Mode

Wait for a trigger sequence and take a snapshot. See Catching a specific sequence...

 

snapshot_stop Stop Snapshot Mode

Abort a snapshot and reenable the communication window display.

 

console_on Keyboard Console On

Enable the keyboard console to send keyboard input directly.

 

console_off Keyboard Console Off

Disable the keyboard console.

 

Show Notepad

Show the notepad window.

 

PROPERTIES Project Settings...

Select the current project settings (COM ports, baud rate, ...).

 

WRENCH Options...

Select general program options (e.g. display mode, date / time stamp).

 

Expert Options...

Select expert program options intended for advanced users and specific applications (e.g. high monitoring accuracy).

 

Scripting Menu

 

Startscript_new Run / Continue Script

Execute the code in the script editor.

 

Stopscript_new Stop Script

Stop a running script.

 

PauseScript_new Break Script

Interrupts a running script.

 

New Script

Close the current Docklight script and create a new one.

 

Open Script ...

Close the current Docklight script and open another script.

 

Save Script / Save Script As ...

Save the current Docklight script.

 

Show Editor / Hide Editor

Show / Hide the script editor window. If the script editor is hidden, the communication window expands to full height.

 

Customize / External Editor...

Use an external editor instead of Docklight's built-in editor.